Invoice Creation and Closure Issue

Incident Report for TimeTap

Resolved

A fix has been deployed and tested.
Posted Feb 05, 2026 - 14:13 EST

Identified

At this time, our development team is aware of the issue and is actively working on a solution to fix the issues with Invoicing.
Posted Feb 05, 2026 - 13:44 EST
This incident affected: US (Backoffice - US).