A solution has been put in place to resolve intermittent error loading messages on client side schedulers.
Posted Sep 22, 2026 - 11:14 EDT
Investigating
Currently, some TimeTap client side booking sites are not loading and displaying an error. Our development team is currently working to investigate and solve the issue.
Posted Sep 22, 2026 - 10:19 EDT
This incident affected: US (Client Scheduler - US).