Users may experience errors logging in and slow loading in Back Office
Incident Report for TimeTap
Resolved
This incident has been resolved.
Posted Feb 24, 2022 - 18:03 EST
Update
We are continuing to investigate this issue.
Posted Feb 24, 2022 - 17:58 EST
Investigating
We are currently investigating this issue.
Posted Feb 24, 2022 - 17:37 EST
This incident affected: US (Client Scheduler - US, Backoffice - US).