Accounts with a Square payment portal connected are currently experiencing an issue on the client scheduler loading the payment form where card info is entered
Incident Report for TimeTap
Resolved
This incident has been resolved.
Posted Mar 24, 2023 - 17:36 EDT
Monitoring
Our development team has identified the cause of this issue and has pushed a fix to address it that is now live on all client schedulers. We are currently monitoring this fix to ensure that everything is back to normal, and we will update this page again once we have confirmed that the issue has been fully resolved.
Posted Mar 24, 2023 - 16:11 EDT
Investigating
We are currently investigating this issue.
Posted Mar 24, 2023 - 12:28 EDT
This incident affected: US (Client Scheduler - US).