Gateway Time Out On Back Office and Client Side Scheduler

Incident Report for TimeTap

Resolved

This incident has been resolved.
Posted Mar 24, 2026 - 11:38 EDT

Monitoring

A fix has been implemented and we are seeing the Back Office and Client Schedulers working as intended.
Posted Mar 24, 2026 - 11:24 EDT

Update

We are continuing to investigate this issue.
Posted Mar 24, 2026 - 09:21 EDT

Investigating

Currently users are experiencing a Gateway Time-Out when accessing TimeTap's Back Office and Client Side scheduler sites. We are working to identify the cause of this issue.
Posted Mar 24, 2026 - 09:21 EDT
This incident affected: US (Client Scheduler - US, Backoffice - US).