Delay In Emails Manually Sent Through Back Office

Incident Report for TimeTap

Resolved

Emails should be operational and working as expected.
Posted Feb 17, 2025 - 18:30 EST

Identified

At this time, emails that are created by a user and sent through the TimeTap Back Office have a significant delay.
Posted Feb 17, 2025 - 06:15 EST
This incident affected: US (Backoffice - US).