Slow Loading Times in Back Office and Client Scheduler

Incident Report for TimeTap

Resolved

Slow loading times experienced on both the Back Office and Client Scheduler have been resolved.
Posted May 12, 2026 - 16:21 EDT

Investigating

We are investigating slow loading and long wait times in both the TimeTap Back Office and client side scheduling.
Posted May 12, 2026 - 15:46 EDT
This incident affected: US (Client Scheduler - US, Backoffice - US).