Users of the Office 365 with Teams (BETA*) calendar sync are currently experiencing event syncing issues.
Incident Report for TimeTap
Resolved
The issue affecting syncing for the Office 365 with Teams (BETA*) integration has been resolved. Teams calendars should be syncing successfully now without any further action.

If you have TimeTap appointment that generated an individual Teams meeting link during the outage, then that link may not be operational at this time. We suggest either rescheduling the appointment so a new meeting link can be issued to the user by TimeTap or sending a separate invitation template with a valid link to the users for any affected meetings. You can set-up the link manually in your Teams calendar, then copy and paste it into a generic invitation template directly on the appointment in the "Appointment Emails" tab of the Appointment itself by clicking "Send Email." Sending links via an invitation template should help to supply these users with a valid link to meet through in the meantime.
Posted Aug 09, 2023 - 10:54 EDT
Update
We are continuing to monitor for any further issues.
Posted Aug 09, 2023 - 09:49 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 09, 2023 - 09:40 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Aug 08, 2023 - 10:04 EDT
Investigating
We're currently investigating an issue affecting users of our Office 365 with Teams (BETA*) integration. Users may be experiencing difficulties with event syncing between TimeTap and Office 365/Teams. Our team is actively working on resolving this issue and restoring seamless synchronization. Continuing updates will be made to this page as the issue is identified and resolved.
Posted Aug 07, 2023 - 09:23 EDT
This incident affected: US (Backoffice - US).