Slow loading times in back office
Incident Report for TimeTap
Resolved
This issue has been resolved, loading times are back to normal.
Posted 7 days ago. Dec 04, 2018 - 12:04 EST
Identified
A solution has been put in place, loading times are improving.
Posted 7 days ago. Dec 04, 2018 - 11:40 EST
Investigating
We are experiencing longer than usual loading times in back office. Our team is currently investigating the root cause.
Posted 7 days ago. Dec 04, 2018 - 11:19 EST
This incident affected: Backoffice.